Errors when trying to run simulations

After successfully running the “Wildfire - Regrowth” simulation with walkthrough. I changed the value of “forestDensity” and now it keeps getting this error whenever I run:

ERROR running simulation: Unknown behavior ‘@hash/create_scatters.js’

Also, I tried running the “City Infection Model” and got this error:

ERROR running simulation: Unknown behavior ‘@hash/create_stacks.js’

Thanks for flagging to us. We’ve heard of a few people having this type of shared behavior bug. What browser are you using?

One way you can fix this now, while we work on the backend fix, is to readd those shared behaviors to the simulation. Search the index of shared behavior, select the missing one, and readd.

I’m on Safari Version 13.1.1 (15609.2.9.1.2). macOS Catalina version 10.15.5 (19F101).

1 Like

Hi Edward, we’ve now fixed this particular error, which was to do with the way Safari handled shared behaviors in HASH, and have updated our corresponding tests as well. Thanks for your patience and flagging this in the first place!

1 Like